DNS resolution failure
Incident Report for Percy
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 15:32 PDT
Monitoring
DNS resolution is working currently. We will continuing monitoring the Cloudflare incident: https://www.cloudflarestatus.com/incidents/b888fyhbygb8

A small number of renders were affected during the 10 minute period starting at 2:14 pm PT, which may have resulted in renders that timed out.
Posted Jul 17, 2020 - 14:53 PDT
Identified
The outage has been identified as a DNS resolver problem with Cloudflare, affecting many sites. See https://www.cloudflarestatus.com/ for more info.

Currently, resolution seems to be sporadicly failing but working in many regions, so we are downgrading this outage from Major to Degraded performance.
Posted Jul 17, 2020 - 14:39 PDT
Investigating
We are receiving reports of widespread DNS resolution failures affecting percy.io and potentially other unrelated sites. We are investigating.
Posted Jul 17, 2020 - 14:36 PDT
This incident affected: Web and API.