We have resumed normal operations and cleared up Percy backlog of builds. Build processing speed is back to normalcy
Posted Nov 18, 2025 - 11:17 PST
Update
We have resumed normal operations and cleared up Percy backlog of builds. Build processing speed is back to normalcy
Posted Nov 18, 2025 - 11:16 PST
Update
We have resumed normal operations. Queued Percy builds are now being processed. Build speeds may be slower than usual while we work through the backlog. We have scaled up our infrastructure to clear the backlog as quickly as possible
Posted Nov 18, 2025 - 09:47 PST
Update
percy.io is currently accessible; however, build processing performance is degraded due to an ongoing Cloudflare incident. As a result, active builds are being queued on our infrastructure. We will resume normal build processing once Cloudflare fully resolves the issue.
Posted Nov 18, 2025 - 07:44 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 04:48 PST
Monitoring
Cloudflare seem to have recovered, we are monitoring the situation.
Posted Nov 18, 2025 - 04:18 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 04:00 PST
Identified
The downtime is related to ongoing Cloudflare outage - we are monitoring the status
Posted Nov 18, 2025 - 03:58 PST
Investigating
We are currently investigating this issue.
Posted Nov 18, 2025 - 03:55 PST
This incident affected: Percy, App Percy, Web, API, and Rendering infrastructure.