Partial Service Disruption

Incident Report for Percy

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 13:56 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 13:47 PDT

Identified

We are experiencing a partial service disruption due to widespread outages with our cloud providers, including Cloudflare and GCP. Our team is actively monitoring the situation and will post further updates as they become available.
Posted Jun 12, 2025 - 12:42 PDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 11:44 PDT

Investigating

We are currently investigating elevated error rates affecting parts of our backend infrastructure. This may result in intermittent failures or delays in processing builds or visual comparisons. Our engineering team is actively working to identify and resolve the issue.
We will provide an update as soon as more information is available.
Posted Jun 12, 2025 - 11:32 PDT
This incident affected: Percy, App Percy, API, and Rendering infrastructure.