Percy API faced degradation for brief period

Incident Report for Percy

Resolved

The issue has been resolved.
Posted Feb 26, 2025 - 22:18 PST

Monitoring

The fix has been rolled out and we are monitoring it.
Posted Feb 26, 2025 - 22:17 PST

Identified

We have identified the issue.
Posted Feb 26, 2025 - 22:07 PST

Investigating

We faced a degradation of the service for a brief period for certain users, we have observed few builds failing intermittently during this brief period.
Posted Feb 26, 2025 - 22:05 PST
This incident affected: Percy.