Team email invites are currently delayed
Incident Report for Percy
Resolved
This issue has been resolved. Please reach out to support@percy.io if you are missing any team invites.
Posted Jan 16, 2019 - 10:16 PST
Investigating
We're investigating an issue of delayed email invites. We'll update the status here when we have more information.
Posted Jan 16, 2019 - 09:31 PST