Degraded performance in percy - builds taking longer to finish

Incident Report for Percy

Resolved

This incident has been resolved.
Posted May 25, 2024 - 11:38 PDT

Monitoring

We had jobs pending in queue causing delay's in build processing. We have fixed the scaling issue and queue is cleared.
Posted May 25, 2024 - 10:40 PDT

Investigating

We are currently investigating this issue.
Posted May 25, 2024 - 09:41 PDT
This incident affected: Percy, App Percy, and Rendering infrastructure.