Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 29, 2024 - 23:00 PDT
Scheduled
There will be a scheduled maintenance of our production databases in the specified timeframe. During this maintenance window, you might face issues while accessing percy.io or logging in using browserstack.com for up to 15 minutes. We apologise for the inconvenience caused.
Posted Mar 11, 2024 - 04:51 PDT
This scheduled maintenance affected: Percy, App Percy, Web, and API.