Intermittent prompts showing up in Safari on iPhone snapshots
Incident Report for Percy
Postmortem

Percy builds running on Safari on iPhone browser intermittently had prompts showing up causing unintended diffs. This issue first started occurring on 26th May and gradually became more frequent. The major impact on builds was observed between 30th May to 6th June. Although we started rolling out fixes for this issue by 30th May itself, due to the reactive nature of the fix some customers might have noticed these prompts till 6th June. We are sorry for any inconvenience caused due to this issue, if you still notice any such prompts, please reach out to support.

Posted Jun 09, 2023 - 06:52 PDT

Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 15:15 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 05, 2023 - 14:23 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2023 - 14:12 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 05, 2023 - 06:48 PDT
Investigating
We are noticing newer prompts in Safari on iPhone browser which are not covered by the fix we implemented in the last incident. We are currently investigating the issue.
Posted Jun 05, 2023 - 02:56 PDT
This incident affected: Rendering infrastructure.